Knowledge Base & Discussion Forum

Unable to rebuild index errors

Discuss technical questions on AhsayOBS

Moderator: Support Team

Unable to rebuild index errors

Postby JohnPCG » Fri Sep 25, 2015 5:29 am

We're seeing a large number of indexes that are failing to rebuild. On the OBM client we see "Error: Unable to rebuild index after 5 retries." On the OBS server we see two errors (some info obscured):
[error][system][BackupSetBFS.rebuildPath2Root] Unexpected IOException. User='<USER>' BackupJob='Current' ClientPath='<FILE>'
and
[error][system][BackupSetBFS.rebuildIndexDir] Exception

In an attempt to fix this I've done the following:
1) Stop the scheduled backup job from running
2) Removed index.bdb and r-index.bdb from the failed jobs
3) Performed the single user rebuild with verify checksum on the backup sets

When step 3 kicks off, we start seeing the "Unexpected IOException" errors all over again. Eventually the index rebuild stops, and trying to start the backup from the client brings back the same "Unable to rebuild index after 5 retries" errors. All agents are running 6.27, and their credentials are correct and have access to the files they're trying to back up.

This is a real head-scratcher, any ideas what else to try?
JohnPCG
 
Posts: 2
Joined: Fri Sep 25, 2015 5:07 am

Re: Unable to rebuild index errors

Postby yasha » Fri Sep 25, 2015 9:25 am

JohnPCG wrote:Unexpected IOException


Sufficient free disk space on user home volume?

If user home is on network-attached storage, what is storage latency under high load?
yasha
 
Posts: 134
Joined: Wed Feb 22, 2012 4:33 am

Re: Unable to rebuild index errors

Postby Support2 » Fri Sep 25, 2015 10:15 am

Hello,

In addition you need to check your user home drives for any disk related errors.

You mentioned the AhsayOBM/AhsayACB clients are on v6.27. I assume your AhsayOBS server is also on v6.27?
User avatar
Support2
 
Posts: 390
Joined: Thu Oct 18, 2007 5:53 pm

Re: Unable to rebuild index errors

Postby JohnPCG » Tue Sep 29, 2015 3:55 am

The AhsayOBS server is on 6.27. I'm not sure the exact numbers on the latency between the OBS server and the NAS (our storage guy has been out the past few days), but I do know that each connection is capped so that one job doesn't take too much. There's sufficient space, however, and I'm not seeing any I/O errors in the event log.
JohnPCG
 
Posts: 2
Joined: Fri Sep 25, 2015 5:07 am

Re: Unable to rebuild index errors

Postby Support2 » Tue Oct 06, 2015 11:48 am

Hello,

I think to be on the safe side you should consider running a disk check on the affected user home drive.
User avatar
Support2
 
Posts: 390
Joined: Thu Oct 18, 2007 5:53 pm

Re: Unable to rebuild index errors

Postby Supportmand » Sun Apr 17, 2016 8:04 pm

Hi.
Did you end up changing anything in you setup??
What did you do to overcome this issue?

It would be nice with an update.
Supportmand
 
Posts: 12
Joined: Sat May 02, 2015 3:39 am
Location: Valby


Return to AhsayOBS

Who is online

Users browsing this forum: No registered users and 1 guest

Looking for Rbackup Alternative | Vembu Alternative | Novastor Alternative | Asigra Alternative | BackupAgent Alternative? Try our product.


A wholly owned subsidiary of Ahsay Backup Software Development Company Limited  [HKEx Stock Code: 8290]